Uploaded image for project: 'Planet4'
  1. Planet4
  2. PLANET-5055

Upgrade ElasticPress to 3.5.x


    • Icon: Task Task
    • Resolution: Released
    • Icon: Should have Should have
    • 2.44.1
    • None
    • 5
    • Search, Technical Debt
    • Sprint #147, Sprint #148, Sprint #149
    • titan

      We are using ElasticPress "3.2.x", while latest is "3.5.x". This would require some investigation to check any breaking changes but also take advantage of new improvements.


      • Check the upstream Changelog for breaking or notable changes
      • Test new version and update base-fork composer file
      • Test along with WPML
      • Fix any breaking changes so that the plugin works with our current code/setup
      • Open new tickets if needed for any enhancements we can do based on new features
      • Check if this fixes the UI bug in the ElasticPress settings (it's not possible to save feature settings because of missing attributes in the markup, data-field-name and value on checkbox inputs). If it's not fixed it could be an issue on our side, as it's a pretty severe bug so they probably would have fixed it. This is tracked at PLANET-5395

            sdeshmuk Sagar Deshmukh
            nroussos Nikos Roussos
            0 Vote for this issue
            0 Start watching this issue