Uploaded image for project: 'Planet4'
  1. Planet4
  2. PLANET-5384

Jquery causes issues in local development

    XporterXMLWordPrintable

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Must have
    • Resolution: Released
    • Affects Version/s: None
    • Fix Version/s: 2.38.1
    • Labels:
      None
    • Story Points:
      3
    • Sprint:
      Sprint #142, Sprint #143
    • Section:
      Campaigns, Dev Tools
    • Track:
      Development
    • Repositories:
      planet4-plugin-gutenberg-blocks

      Description

      I'm not sure why this only happens locally for me, but the editor crashes on https://github.com/greenpeace/planet4-plugin-gutenberg-blocks/blob/7f05fad20403c7ec700f05ed7e8c979911db9884/assets/src/BlockEditorValidation.js#L12-L12 because $ is not defined. We can rewrite the code in that file to not use jQuery.

        Gliffy Diagrams

          Attachments

            Activity

              People

              Assignee:
              pvincent Pieter Vincent
              Reporter:
              pvincent Pieter Vincent
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: