Uploaded image for project: 'Planet4'
  1. Planet4
  2. PLANET-5076

Upgrade to a supported version of phpunit

XMLWordPrintable

    • Icon: Task Task
    • Resolution: Fixed
    • Icon: Should have Should have
    • None
    • None
    • 3
    • Testing
    • Sprint #138

      Our theme and plugins still use phpunit 6, but that version is not supported anymore since over a year. The documentation for 6 has even been removed from phpunit's website.

       https://github.com/greenpeace/planet4-master-theme/blob/5da9b14c608cb0063175326708db78238fa40bf7/composer.json#L41

      https://phpunit.de/supported-versions.html

      Tasks

      • Investigate if needed to update
        If needed:
      • Update phpunit to latest version
      • Make sure unit tests on CI keep running as expected
      • Make sure local dev environment is not affected by these change
         

            pvincent Pieter Vincent
            pvincent Pieter Vincent
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Created:
              Updated:
              Resolved: